Don't display street number on order detail

anhdinh89anhdinh89 Posts: 10Member
edited October 18 in Development
Hi everybody,

I have created a order via API, and get it by API, the addressBillingNumber have already

 "addressBillingName": "andy Jing",
  "addressBillingStreet": "Silver Hollow",
  "addressBillingStreet2": "",
  "addressBillingNumber": "43",
  "addressBillingExtension": "",
  "addressBillingZipcode": "08902",
  "addressBillingCity": "North Brunswick Township",
  "addressBillingRegion": "New Jersey",
  "addressBillingCountry": {
    "id": 226,
    "code": "us",
    "code3": "usa",
    "title": "United States"
  },

but on lightspeed admin, I don't see the addressBillingNumber at order detail





How do I setting to display  the addressBillingNumber(house number) on order detail?

also the map at order detail is not working, how do I enable map ? 

3 comments

  • jamesratcliffejamesratcliffe Posts: 153Administrator, Lightspeed Staff moderator

    @anhdinh89 In the USA and Canada, the House number isn't a separate field in the address.

    When send an address for either country, include the house number in the address(Billing|Shipping)Street ("43 Silver Hollow"), and don't include the address(Billing|Shipping)Number.

    The format you used above is correct for every other country.

    James Ratcliffe
    API Integrations Specialist
    Lightspeed HQ
  • anhdinh89anhdinh89 Posts: 10Member
    Hi James,

    thank for your response, we will update our code


  • jamesratcliffejamesratcliffe Posts: 153Administrator, Lightspeed Staff moderator
    You're welcome.
    James Ratcliffe
    API Integrations Specialist
    Lightspeed HQ
Sign In or Register to comment.