The client id supplied is invalid

pochupochu Posts: 2Member
edited November 9 in Development

Hi I have submitted 2 client registrations for the following client ids:

Eminent Technology Client - XXXXXXXXXXXXXXXXXXXXXXXXX

Receive By Storemerce - 
XXXXXXXXXXXXXXXXXXXXXXX

When I follow the instructions listed over here:
https://developers.lightspeedhq.com/retail/authentication/authentication-overview/

eg send link to the following for Eminent Technology client:
XXXXXXXXXXXXXXXXXXXXXXX

I am able to login but get the following error message:
{
"error": "invalid_client",
"error_description": "The client id supplied is invalid"
}

However I am able to login with both client ids to update client details over at the following location:
https://cloud.lightspeedapp.com/oauth/update.php

Can you please tell me what I am doing wrong.

Post edited by Leah on

11 comments

  • mokupniarekmokupniarek Posts: 2Member
    edited November 6
    Hi @Leah,
    I have the same problem with our Client ID / Secret ID. I am getting the same error ("The client id supplied is invalid"). Could you authorize our client on your side asap?

    Client ID: XXXXXXXXXXX

    Client Secret: XXXXXXXXXXX

    What is the fastest way to get client authorization? (I did not receive a confirmation email)
    Post edited by Leah on
  • Jayanta_123Jayanta_123 Posts: 2Member
    edited November 6
    Hi @Leah,
    I have the same problem with our Client ID / Secret ID. I am getting the same error ("The client id supplied is invalid"). Could you authorize our client on your side asap?

    Client Key: XXXXXXXXXXXXXXX

    Client Secret: XXXXXXXXXXXXXXX

    What is the fastest way to get client authorization? (I did not receive a confirmation email)
    Post edited by Leah on
  • LeahLeah Posts: 26Moderator, Lightspeed Staff moderator
    Hi @Jayanta_123, @mokupniarek,
    We had a bit of a backlog approving client requests but yours were approved yesterday evening between 5-6PM EST.
    API Support
    Lightspeed HQ
  • weirhouseweirhouse Posts: 3Member
    Hi @Leah - I’m having the same issue with my Client ID when support chat mentioned it had already been approved. Is there a way for me to submit my client id for approval? 
  • LeahLeah Posts: 26Moderator, Lightspeed Staff moderator
    Hi @weirhouse, Your client ID was indeed approved on November 6th. You had submitted multiple requests, so please ensure you are trying the correct client ID (mentioned in the confirmation email). More instructions on the OAuth workflow can be found in our documentation here.
    API Support
    Lightspeed HQ
  • weirhouseweirhouse Posts: 3Member
    Thanks @Leah! I’m unable to find any sort of confirmation email on that day. Are you able to provide the email it went to? Or resend the confirmation?
  • weirhouseweirhouse Posts: 3Member
    Thank you @Leah - I sent you a DM when you have the chance to get to it. Thanks. 
  • mokupniarekmokupniarek Posts: 2Member
    @Leah

    I’m having the same issue again. I registered new keys 6 days ago - they are still inactive. Can you help me with the activation of this data? 


  • LeahLeah Posts: 26Moderator, Lightspeed Staff moderator
    @mokupniarek you should be good to go. Please check your email.
    API Support
    Lightspeed HQ
Sign In or Register to comment.