Inventory Backorders Not Updateable?

BryseBryse Posts: 2Member

Hello,


I am implementing the eCom API for Lightspeed.

I want to update the value for "inventory_allow_backorders" to true through the API.

This is an option in the webshopapp interface for Variants.

I can't find any API documentation that allows me to update this value for products.


Furthermore, creating a new product with the API will set this value to false automatically. However, I have set the shop up to default the value to true in my workflows. The API always sets this value to false when creating a new product.


How can I fix this issue?

When creating a new product I want to set the value to true always for allowing inventory backorders.

Tags:

2 comments

  • LeahLeah Posts: 45Moderator, Lightspeed Staff moderator

    Hi @Bryse

    Generally, when 'Allow Backorders' is checked under 'Workflow' in the UI, products created via the API will have 'allow backorders' checked. Is it possible that when creating a variant "stockTracking": "disabled" or "stockTracking": "enabled" is included in your payload? This might explain the issue. If using this argument (rather than just the default workflow settings) use "stockTracking": "indicator". This will always activate the inventory tracking and backorders setting, regardless of the default workflow setting.

    If you're still having issues, kindly post an example payload so we can try to further diagnose.

    Thanks!

    API Support
    Lightspeed HQ
  • BryseBryse Posts: 2Member

    Thanks. Adding `stockTracking: "indicator"` fixed the issue.

Sign In or Register to comment.