Yotpo integration stopped on the 22nd of December

PatrickvdHeijdenPatrickvdHeijden Member, Beta tester Posts: 143 ✭

Hello guys,

I have an issue where I would need your help. Since 2013 we are working together with Yotpo as a review partner and has worked fine until the 22nd of December 2019. After that it stopped sending data. I have no clue on how to proceed as it always has been an app and I did not need to understand any of the API lingo.

I am working with Yotpo on this part but now they ask some questions to me and I hope you can help me with these:

------------------

In order for me to deeply investigate on this, I will need your help to contact Lightspeed and ask "if the API call that were sent to submit Orders have responded "200" it would help us solve the issue quickly if they can provide screenshot or share the payload. 

  • If Lightspeed tells you that the API call for Orders responded "200", please ask for at least 3 "uuid"(needed to check in our system if the API call has reached to our server) - any 3 uuid from Order date Dec 22 2019 on-wards.
  • Please also mention to Lightspeed to check if it is properly integrated to Yotpo( I've check in our system and can see no API call for your Orders has been submitted )
  •  If everything mentioned above is true, go ahead and try to re-install Yotpo App (follow this article to install Yotpo in Lightspeed - let me know when this is done.

-------------------

Do you have any suggestions on how I can proceed with this?

Groet,
Patrick van der Heijden
www.sceneryworkshop.nl

5 comments

  • LucienVersendaalLucienVersendaal Moderator, Lightspeed Staff Posts: 283 moderator

    Hi @PatrickvdHeijden,

    Thank you for reaching out to us.

    What I see is that the Yotpo is no longer available in our app store. I would therefore not know to what extent this influences the code that you have placed in the custom.rain. Since the app is no longer supported, this would explain why no API calls are being sent.

    Unfortunately we cannot provide support for code that you have implemented yourself in the code.

  • PatrickvdHeijdenPatrickvdHeijden Member, Beta tester Posts: 143 ✭

    That is strange as there are still other customers where it still is working as it has for years. What could be the reason for that?

    Groet,
    Patrick van der Heijden
    www.sceneryworkshop.nl
  • LucienVersendaalLucienVersendaal Moderator, Lightspeed Staff Posts: 283 moderator

    Sorry I was confused by the article you send, It says that you need to install the app in the Lightspeed App Store. But it's also possible to place some generic code in the header and on product page: https://support.yotpo.com/en/article/generic-other-platforms-installing-yotpo

    I also mentioned that the code on your product page, you can view this is the back office when you go to Design->Theme Editor ->product.rain you'll see that the Yotpo code block is commented out, so this code isn't working at the moment.

    If you look at the revisions you can see that a number of changes have recently been made.

    Could you explain to me why this is commented out?

  • PatrickvdHeijdenPatrickvdHeijden Member, Beta tester Posts: 143 ✭

    This code has been replaced to another spot at the bottom of this Rain file as it should be shown under the other content at the moment.

    Groet,
    Patrick van der Heijden
    www.sceneryworkshop.nl
  • LucienVersendaalLucienVersendaal Moderator, Lightspeed Staff Posts: 283 moderator
    • If Lightspeed tells you that the API call for Orders responded "200", please ask for at least 3 "uuid"(needed to check in our system if the API call has reached to our server) - any 3 uuid from Order date Dec 22 2019 on-wards. Here you have some orders from Dec 22 https://scenery-workshop.webshopapp.com/admin/orders?page=9&created_at_gt=2019-12-21. Order1ID:144737212 Order2ID:144737987 Order3ID:144739066
    • Please also mention to Lightspeed to check if it is properly integrated to Yotpo( I've check in our system and can see no API call for your Orders has been submitted ) Unfortunately we do not support custom code. You'll need to compare the code from https://support.yotpo.com/en/article/generic-other-platforms-installing-yotpo with the actual code that is on your website.
    •  If everything mentioned above is true, go ahead and try to re-install Yotpo App (follow this article to install Yotpo in Lightspeed - let me know when this is done. The app is no longer available in the app store of Lightspeed.


Sign In or Register to comment.