eCom API returns 502: Bad Gateway on Sept 27th from 22:45 to 23:00 CET

JMango360JMango360 Member Posts: 3
edited October 1 in Development

Hi LightSpeed,

My name is Nam from JMango360. We provide eCommerce app solution for our customer names Wijncollectief - Shop ID is 112598. The shop URL is https://www.wijncollectief.nl/

During the period from 22:45 to 23:00 CET on Sept 27th, there are multiple app users cannot use the app. The app shows an error "502: Bad Gateway".

We checked on our server log and see that there are a lot of requests from our server to your API that returns "502: Bad Gateway". The issue was automatically resolved after 23:00. See the below:

Here is an example of a request:

We think there might be some issue with LightSpeed API during that period. But I cannot see any report in this link:

Please let us know if that is an issue from your site.

The customer Wijncollectief really wants to know what happened?

Thanks,

1 comment

  • LucienVersendaalLucienVersendaal Moderator, Lightspeed Staff Posts: 406 moderator

    Hi @JMango360,

    Thank you for reaching out to us.

    In the future you can reach out to us directly since you are a partner.

    I checked this with our devs, and there was a little spike of the traffic. Keep in mind that all eCom apps are connected, so slowness in one app can have negative effect on others. In this case, APi uses the checkout from storefront, so if SF(storefront) is slow, API has issues as well with that part. So it sounds connected and related.

    I hope this helps.

Sign In or Register to comment.