Lightspeed Through a VPN

korybkoryb Partner Posts: 3 partner
We have used Lightspeed successfully for several years, including remote access using an external IP address on our Lightspeed server. We recently implemented a SonicWall VPN, converting all our Macs to internal IP addresses. I can connect externally to the VPN, and through it screen sharing and file sharing work fine. However, I can no longer access Lightspeed externally. I tried adding the :9630 extension to the server's new internal IP address, but that didn’t help.

I have searched for resources on how to connect to Lightspeed through a VPN but have been unsuccessful. Has anyone else found any guides or other tips on how to make it work?

Thanks in advance!


  • [Deleted User][Deleted User] Posts: 0
    koryb - you would have to do port forwarding from the external IP on 9630 to the internal IP on 9630. Additionally you do not have to add 9630 to the internal IP like you did as Lightspeed Server listens on 9630 by default.
  • korybkoryb Partner Posts: 3 partner
    Hi Marshall, thanks for the quick reply. I sincerely appreciate it.

    Can you please clarify your suggestion? When you say forward from the external IP, my Lightspeed Server no longer has one. It now has an internal IP. Do you mean forward the external IP of the Gateway to the Internal IP of the Lightspeed Server?

    I can do that, but I guess I thought if I was connected to the VPN my network would see me as if I were inside the network, and as such port forwarding wouldn't be necessary. For example other Macs in our store, with Internal IP's, can see the Lightspeed Server OK.

    Thank you again!
  • [Deleted User][Deleted User] Posts: 0

    If you are connected to the VPN then you do not need to do any port forwarding. Simply open the Lightspeed Application and click on Servers. Click the Add button and then type in a name and the internal IP of your server, you do not have to put :9630 onto the end of the IP unless your server is running on a different port. To find out which port your server is running on, go to the Lightspeed Server machine, and go to System Preferences -> Lightspeed Server and then look at the number next to Port.

    Hope this helps!
  • korybkoryb Partner Posts: 3 partner
    I just wanted to leave a follow-up message in case anyone else looks up this issue. I now have the solution working. To confirm, setting up port forwarding on the SonicWall was not necessary. Once connected to the VPN, I entered the internal IP address of the server without any suffixes and was able to connect just fine. I really didn't change anything since I posted my initial question. After Marshall confirmed I was approaching it properly I just retraced my steps; not sure what I was doing wrong before but it is now working. Thanks Marshall for the guidance!
  • agscanadaagscanada Member Posts: 44 ✭
    Hi Koryb,
    Everything still working OK?

    We are looking at setting up a VPN but have not used one in the past.

  • Ridge GoodwinRidge Goodwin Member Posts: 1
    Hi Koryb,

    We are looking to set up a VPN and was wondering if you could kindly demonstrate how to do so step by step?
  • andyjames77andyjames77 Member Posts: 1
    kindly also describe the method briefly because I also want to implement on my FastestVPN or is there any guide on it so kindly share with us.

    Thanks, Koryb
  • YorickYorick Moderator, Lightspeed Staff Posts: 13 moderator

    Each VPN is different and has its own setup instructions. You can find some general guidelines by searching on Google.

    @andyjames77 You can find FastestVPN guide here:
    I would recommend to contact their support if you have any questions.
    API integration specialist
    Lightspeed HQ
  • DanMDanM Member Posts: 1
    edited July 2019

    Hi there... Just wanted to chime-in that I had a client request remote access to their Lightspeed server, so before resorting to a VPN (and all the administrative baggage the comes along with it) I gave SSH tunnelling a shot. Turns out it works great when you click the little globe icon and select Modern authentication.

    I would recommend using SSH keys and setting a nonstandard port on the firewall (port 22 is constantly probed)

    When you need remote access, open terminal and run something like:

    SSH -L 9630:<INTERNAL_IP_OF_SERVER>:9630 [email protected]<EXTERNAL_IP_OR_DDNS>



Sign In or Register to comment.