Item Custom field value is cached in browser

NiguNigu Posts: 5Member
Item Custom Field value is cached in browser so I can't see new value when Item updated via API call till I clean up browser data. Also old value will override new one if I save Item in browser. Is there any workarounds for this issue or could it be addressed? Thanks!

BTW, "API Developers -> Retail API -> Development" Discussion category is not available..

7 comments

  • jamesratcliffejamesratcliffe Posts: 160Administrator, Lightspeed Staff moderator
    @Nigu I'm not able to reproduce this. If I update a custom field value, I see the new value on the item. I just have to reload the page if I have it open when I update the value.

    Are you using Firefox or Chrome? Retail might not behave correctly on other browsers.

    Also, I'm able to open the "API Developers -> Retail API -> Development" section with no issue. It sounds like there might be something weird happening with your web browser.
    James Ratcliffe
    API Integrations Specialist
    Lightspeed HQ
  • NiguNigu Posts: 5Member
    Oh yes, page reload works (I was confused because F5 doesn't reload page, just navigate into Customers). But if you leave Item page and just navigate through Retail site without page reload (go to Inventory, then Item Search, then open changed Item) - then open Item page again - you will still see old values.

    Browsers: Firefox, Chrome, Microsoft Edge

    About New Discussion menu - now I can choose "Retail API -> Development", but still can't choose "Retail API -> Tutorial", and some other menu items are disabled, see https://imgur.com/a/7rTpz
  • NiguNigu Posts: 5Member
    Note: another fields, like "customSku" will be updated after site navigation usage.
  • jamesratcliffejamesratcliffe Posts: 160Administrator, Lightspeed Staff moderator
    After testing, I can see that the custom field values aren't refreshed unless you reload the page. Our Development team will look into this.
    James Ratcliffe
    API Integrations Specialist
    Lightspeed HQ
  • jamesratcliffejamesratcliffe Posts: 160Administrator, Lightspeed Staff moderator
    As for the disabled forum section when starting a new discussion, I did see that this morning, but now all the options are available. We'll look into it.
    James Ratcliffe
    API Integrations Specialist
    Lightspeed HQ
  • NiguNigu Posts: 5Member
    Thank you James!
  • jamesratcliffejamesratcliffe Posts: 160Administrator, Lightspeed Staff moderator
    You're welcome!
    James Ratcliffe
    API Integrations Specialist
    Lightspeed HQ
Sign In or Register to comment.