Verifone P400 Locking Up.

Jude24Jude24 Member Posts: 1

We have had several instances where a Verifone P400 payment terminal locks up after the customer runs the card. On the POS screen it says "follow instructions on payment terminal" and the loading icon (spinning circle) shows continually. The payment terminal doesn't show anything. The only way we have been able to correct it is to close Lightspeed Retail and re-open it. Sometimes the payment goes through, and sometimes it doesn't. Has anyone experienced this?

Answers

  • VanessaDVanessaD Moderator, Lightspeed Staff Posts: 643 moderator

    Hey @Jude24

    We recommend calling support so we can try and determine the root cause of this since this is specific to your particular device.

    ———


    If you have any further questions Please do not hesitate to contact LightSpeed support or check out our Support Page.


    All the best!

    Vanessa

    Lightspeed Retail Support

    866-932-1801 ext. 2 (Toll-Free)

    514-907-1801 ext. 2 (Montreal)

  • eddiesuarezeddiesuarez Member Posts: 10

    We have had this happen to use too sporadically. I appreciate VanessaD suggesting we call support but the customer is not going to stand around waiting while we do. Closing LS and Restarting has been our way to remedy it as to not keep the customer waiting and the queue getting longer.

  • AlanDAlanD Member Posts: 2

    It seems we may have found a fix for this situation. We have two registers/terminals. Upon opening we previously logged into both using the same credentials. After reading some comments here we began using different users to log into each register and this problem has not recurred yet.

    Note: This issue was the POS locking up and not allowing completion of the sale on the terminal. This is a separate issue from the Verifone terminal going offline and requiring a power cycle.

  • johnhjohnh Member Posts: 3

    We also had many issues with the Verifone terminal. We eventually gave up and went iPad with BBPos. We still have occasional problems processing cc payments but in general things are running smoother.

  • workerchimpworkerchimp Member Posts: 11

    This is a HUGE problem! My Verifone P400 must constantly be power cycled multiple times throughout each day. Every time, I lose customers because the terminal just sits there and does not acknowledge that the iPad app is requesting a payment from it. So far, I have been told to check the iPad's internet setting for the DNS to manually be entered as 8.8.8.8. No luck. Any other ideas Lightspeed?

Sign In or Register to comment.