Worldpay MX-915 terminals intermittently (and annoyingly) slow

2>

55 comments

  • alanlloydalanlloyd Member Posts: 76 ✭

    One more item of note: The chat support person said that my account would be included in an "investigation" that Lightspeed was doing regarding this problem. So, assuming there is an investigation, that means that this is a known or suspected issue at Lightspeed.

  • CapeFearGamesCapeFearGames Member Posts: 18

    Alan we have previously tried this. Is this still working for you though?

  • alanlloydalanlloyd Member Posts: 76 ✭

    I checked yesterday with my staff and they told me that they haven't seen it take over about 30-45 seconds . . . and that they are no longer seeing the two or three minute delays. They said that most terminal wake-ups (for lack of a better word) happen within 5-15 seconds at this point. All that said . . . .realize that I am asking people for whom working as a cashier is a career stretch. I haven't personally seen it take what I would consider an exceedingly long time though . . . .since this "fix" was implemented almost a week ago.

  • CapeFearGamesCapeFearGames Member Posts: 18

    I'll try this again today and report back.

  • jburkeen03jburkeen03 Member Posts: 2

    I’ve tried everything Lightspeed chat has recommended along with deleting the device from Lightspeed and while it may work relatively fast for a day or two it will resort back to slow wait times. It just a temporary fix if it’s incredibly slow. Rebooting through the device seems to temporarily help but none of these will fix the actual problem permanently.

  • CapeFearGamesCapeFearGames Member Posts: 18

    We did this fix and so far we haven't had anything over 30 seconds. Will report back on Monday.

  • alanlloydalanlloyd Member Posts: 76 ✭

    It'd be cool if someone from Lightspeed would comment on this . . . give an update on what is happening to investigate and fix this, etc. Evidently it is a known issue because my support person said it was an on-going investigation.

    I think that this group is only moderated by one person at Lightspeed. Vanessa?

  • TreasuresofojaiTreasuresofojai Member Posts: 3

    We received the Wise E terminals today. Easy installation and so far working really well! Response time from up to 3 minutes to 5 seconds. This is definitely a Lightspeed issue not a router or connection issue.

  • CVLSCVLS Member Posts: 18

    Thank you for reporting back! If it really is just a terminal issue then I am eager to switch to the Wise E terminals so my employees and customers no longer have to deal with this issue and we can finally put this problem behind us.

  • TreasuresofojaiTreasuresofojai Member Posts: 3

    We'll confirm the results after this weekends business. Currently accepting "tap" payment and Apple Pay very easily.

  • CapeFearGamesCapeFearGames Member Posts: 18

    The fix did seem to help for a while but it's back to going slow again. We haven't had any take 3 minutes yet but we had one take 1 minute yesterday and they are all much slower than they should be.

  • CapeFearGamesCapeFearGames Member Posts: 18

    Looks like the Wise terminals are just for LS payments which we do not use. One of the top reasons we went with lightspeed was the flexibility they offered their customers. I don't want to feel forced to switch to their payment service, I would much rather switch if I feel what they are offering is beneficial.

  • CVLSCVLS Member Posts: 18

    Yes, I was told I can't switch to Wise terminals either unfortunately.

  • CapeFearGamesCapeFearGames Member Posts: 18

    It has been terrible today so I would say it's definitely not fixed.

  • mccallpetmccallpet Member Posts: 3

    We've been experiencing the same issues since the holidays on Worldpay Vantiv on our Ingenico iPP320's. Extremely frustrating and a huge time/money waster.


  • CapeFearGamesCapeFearGames Member Posts: 18

    We have a whole timestamped internal message board with our staff to track the issues and it's been terrible lately with plenty of 1+ minute wait times from when we hit accept credit card to when something changes on the terminal. Lightspeed can you please give us some sort of update?

  • alanlloydalanlloyd Member Posts: 76 ✭

    No update from Lightspeed here, but I have been working with one of their technicians to try to resolve this. We have tried several different methods, including a completely different ISP (I have two ISPs, so it was easy to switch).

    He thinks that this is not a Lightspeed issue, but I am convinced that it IS.

    Even after switching to a completely different ISP, this problem persists. One time it will be 2-3 seconds for my terminals to activate . . .and the next transaction will take maybe a minute or more!

    We have opened ports that would ordinarily be used for running web services inside our network (443, 4443, 9001). We have changed the DNS configuration, we have disconnected the payment terminals and re-connected them in Lightspeed, we have run packet loss tests, etc. etc. And finally today run on a completely different ISP! I have a 20+ year IT career as an MCSE, and I am convinced this problem does not lie in my computers or network, or even my ISP. I am convinced this is a Lightspeed problem . . . that is also OUR problem! It needs to be FIXED, like yesterday!

    I have asked him to PLEASE try to replicate this issue at Lightspeed and pointed him to this thread to show that I am not an isolated incident.

    Alan

  • gregaricangregarican Member Posts: 926 

    Sounds like the support rep's goal was more to delay addressing the issue than anything else. Figure having you jump through all of those mostly unnecessary hoops. Especially since it's not an isolated issue for just one retailer.

    To start, Verifone is retiring the MX-915 line sooner rather than later. Here again is a bulletin about the specifics --> https://3dmerchant.com/blog/pos-terminals/verifone-end-of-life-terminals. If Lightspeed is still recommending this model in 2022 then that's a problem. More specifics from the bulletin indicate:

    If you have a part number that starts with this “PN 132”, replace the terminal. If you were an early adopter and had your terminals deployed prior to the EMV chip liability shift in October 2015, there’s no need to check part numbers; They need to be replaced.

    If replacing the payment terminal with a different make/model resolves the issue, then it's a matter of Lightspeed recommending a sunsetted piece of equipment. If the replacement doesn't resolve the issue and networking snafus have been ruled out, then it's a matter of Lightspeed's services not scaling up enough to meet retailer demand. 😮

  • alanlloydalanlloyd Member Posts: 76 ✭

    @gregarican Speaking of scaling . . . check my post here from Saturday! Thanks for the insight.

  • RedactedDuckRedactedDuck Member Posts: 1
    edited June 2


    Lets escalate this problem to a new level.

    RT or tweet them, maybe they will respond to public humiliation.

    I'm so fed up.

  • PBTXPBTX Member Posts: 3
    edited June 15

    We've been experiencing the same problems. Started sometime in the last 5-8 months. We just renewed our contract and switched to Lightspeed Payments. The new WisePOS E terminal is still slow to get the payment prompt from Lightspeed.

    On the plus side, it seems customers can insert their card without first waiting for the prompt.

    @Please address and fix this issue @Lightspeed !!

    And yes, we've tried all the fixes previously mentioned.

  • alanlloydalanlloyd Member Posts: 76 ✭

    @PBTX So, what I'm hearing is that Lightspeed can't make this work even with THEIR payment system. That indicates what I have thought all-along: That whatever code or mechanism is used to trigger the terminals is malfunctioning. It has nothing to do with network issues, the terminals, etc.

    BTW, when a customer becomes a lightspeed payments customer, it increase Lightspeed's profits dramatically. The thought crossed my mind to become a LS payments customer to try to fix this problem, but I refuse to do it on principal.

    After about three weeks of bogus and worthless troubleshooting -- to include some generally ill-advised practices regarding DNS and router port configurations --they basically told me that they couldn't fix this. Awesome.

  • fischervanguldenfischervangulden Member Posts: 1

    Having the same exact issue here with the same hardware. Looking into different hardware, any suggestions? Also has anyone else switched hardware and had that fix the issue?

  • cgomescgomes Member Posts: 1

    We are having the same exact issue, but DIFFERENT hardware. We have an iPP320 by Ingenico.

    Sometimes the pin pads get triggered very quickly, other times (as others have experienced) it can take up to 3 minutes. It's insane and customers/employees are becoming less and less patient with it.

    Has anyone had any luck getting Lightspeed to correct the issue or anything else that seemed to show improvement? I've already invested thousands in new network equipment trying to fix the issue....

  • gregaricangregarican Member Posts: 926 

    If the hardware isn't being retired by the manufacturer, then sometimes checking to see if a firmware update is available can be a good first step. Beyond that then it's a ball in Lightspeed's court. Unfortunately there are a few of them bouncing when it comes to quickly resolving issues.

Sign In or Register to comment.