401 Employee can't log in

luke_eastmanluke_eastman Member Posts: 3

I've suddenly been getting an error when trying to update inventory through the Retail (R-series) API that I haven't encountered before. I didn't change anything at the time the error began. Everything was functioning fine up until that point. The error is:

Lightspeed API Error -  401 Employee can't login. Verify that it isn't locked out or archived

I've verified that the employee isn't archived or locked out and also has all possible permissions available to them.

Any thoughts or tips would be greatly appreciated!

Thanks!

Luke Eastman

Owner and Developer at Wittiwise

www.wittiwise.com

3 comments

  • Ali_MasoumieAli_Masoumie Moderator, Lightspeed Staff Posts: 340 moderator

    Hi,

    The error means that the user is locked out or archived. If you have verified that the user is not locked or archived, you can try to re-authorize.

  • luke_eastmanluke_eastman Member Posts: 3

    Thanks for the response @Ali_Masoumie! I have verified that the user is not archived or locked and attempted to re-authorize. I've also verified that the user can login directly to the POS when not using the API. Unfortunately, I'm still getting the same error.

    Do you have anymore thoughts on why this could be happening?

    Luke Eastman

    Owner and Developer at Wittiwise

    www.wittiwise.com

  • Ali_MasoumieAli_Masoumie Moderator, Lightspeed Staff Posts: 340 moderator

    Can you send me the accountID and user information in a PM so that I can have a closer look.

Sign In or Register to comment.