TLS 1.0 End of Life

Michael CareyMichael Carey Administrator, Lightspeed Staff Posts: 68 moderator
This is a reminder that Lightspeed no longer supports TLS v1.0. All integrations will need to use TLS v1.1 or higher to continue to work.

From the PCI Security Standards Council:
30 June 2018 is the deadline for disabling SSL/early TLS and implementing a more secure encryption protocol – TLS 1.1 or higher (TLS v1.2 is strongly encouraged) in order to meet the PCI Data Security Standard (PCI DSS) for safeguarding payment data.
Link


Michael Carey

Product Manager
Lightspeed HQ

2 comments

  • thisconnectthisconnect Member Posts: 6
    edited August 2018
    our server uses TLSv1.2 but connection is lost (support said it was because we still use v1.0) 

    edit: although TLSv1.2 is installed on our server, curl does not use it correctly... i checked with "curl https://tlstest.paypal.com"
    Post edited by thisconnect on
  • jamesratcliffejamesratcliffe Administrator, Lightspeed Staff Posts: 160 moderator
    You need to make sure curl is using TLS 1.2. Upgrading curl might fix this.
    James Ratcliffe
    Lightspeed HQ
Sign In or Register to comment.