Local order never opens the table on till

GuillaumeFGuillaumeF Member Posts: 7

Hello

I have been sending local orders to lightspeed API and orders are stored and visible on the till but orders never open the corresponding table.

First we are using /o/op/1/order/table/XXXX/getCheck to check if table is already opened but it is never opened (error looking up account).

Even after the first (second, third, ...) order, the table remains closed (same error as above) so we are never able to access the accountIdentifier from the getCheck call.


Is there a configuration somewhere so tables are automatically opened when a ticket/order is associated to them ?


(Something strange is that tickets that we create are mentioning the right table, so it seems ok but yet, the table remain closed)

3 comments

  • LucienVersendaalLucienVersendaal Moderator, Lightspeed Staff Posts: 931 moderator

    Hi @GuillaumeF,

    Thank you for contacting us.

    Did you check your webhook endpoint? Here you'll find details when a request is failed.

    Can you send me the full payload?

  • GuillaumeFGuillaumeF Member Posts: 7

    We understood what was going on... It was on our part. Paid orders open and close right away the table. So the table stays closed which is normal.

    With non paid orders, the table opens and stay open and everything is alright.

    The documentation lacks a bit of explanation on the system mechanics


    You can close the ticket, it's ok. Thank you

  • LucienVersendaalLucienVersendaal Moderator, Lightspeed Staff Posts: 931 moderator

    Hi @GuillaumeF,

    Okay perfect!

Sign In or Register to comment.