Worldpay MX-915 terminals intermittently (and annoyingly) slow

alanlloydalanlloyd Member Posts: 76 ✭

Okay -- I know this might be outside the scope of this group (so I don't need a lecture), but I have three MX-915 Verifone terminals and use Worldpay for CC transactions. Over the past month (since the holidays), we have experienced intermittent delays in processing. Sometimes the processing takes place with no problem . . . and the next transaction is exceedingly slow. This happens on every terminal. I have rebooted our routers, cleared our switch caches, etc. etc. etc. We run Windows 10 HP boxes with hard wired Ethernet connection to a redundant fail-over router and use two ISPs. Connectivity and response time on websites (including LightSpeed) is phenomenally fast. It's not a connectivity or IS-related problem.

Any ideas? Are others using Worldpay seeing this?




  • CapeFearGamesCapeFearGames Member Posts: 18

    We are having this exact same problem. I asked in the FB groups but so few people have the exact same setup. We have had some instances where it took up to 3 minutes which is an extremely long time for a customer to stand waiting for it.

    I thought it was LS sending the information to the terminal that was holding it up but I'm not sure.

  • CapeFearGamesCapeFearGames Member Posts: 18

    Can anyone from lightspeed help with this? I've tried support several times but they keep trying to get us to do things on our side and I know we do not have an issue on our side. We have a direct fiber line so our connection is not the issue. The same thing is happening when we try to use our mobile ingenico credit card machine.

    It's gotten so bad that customers are bringing cash so they don't have to wait for our credit card machines.

    Could someone that is more knowledgeable on the situation please help?

  • gregaricangregarican Member Posts: 926 

    At which point do these slowdowns occur?

    = Between the Retail POS sending the prompt over to the payment terminal and the payment terminal requesting the card insert.

    = Between the payment terminal sending the transaction out and waiting for the approve/deny response to display.

    = Between the payment terminal's response being displayed and Retail POS finishing up the transaction.

    If it's the second scenario then that's more of a payment terminal and provider issue. If it's the first or second scenario then it's definitely something that Lightspeed Retail support should assist with.

  • CapeFearGamesCapeFearGames Member Posts: 18

    Retail POS sending the prompt to the terminal. The payment terminal screen does not change at all for up to 2 minutes but on average it's taking 20 seconds which is a DARN long time to ask customers to wait.

    I've mentioned this to LS but they keep trying to get me to do network things on my end such as using google's DNS on our computers, rebooting everything, etc.

  • gregaricangregarican Member Posts: 926 

    Sounds like that's an issue with the payment terminal connecting out in order to retrieve the response. It might be worth it reaching out to Worldpay support in order for them to look at things on their end. If you know your Internet connection is stable and has lots of available bandwidth then it sounds like a payment processor issue.

  • CVLSCVLS Member Posts: 18

    Welcome to the club. We also have blazingly fast internet throughout the entire network, yet the time it takes for the transaction to get to the terminal is abysmal. We've just learned to make conversation with the customers to avoid the inevitable awkward silence and embarrassment during the wait.

  • CapeFearGamesCapeFearGames Member Posts: 18

    Gregarican, I do not know a ton about how terminals work but I'm assuming LS sends the information directly to the terminal and then the terminal waits for a response from worldpay or does LS send the information to the terminal and then nothing is sent to worldpay until the customer swipes?

  • gregaricangregarican Member Posts: 926 

    Typically nothing is sent to the payment processor until the customer swipes/dips/taps their card. At the point that the customer does that and then you see a response on the payment terminal is where the payment processor is on the hook. Any point prior to that or after that I would assume Lightspeed would be on the hook.

  • cottoneyedjoescottoneyedjoes Member Posts: 3

    I am having this same issue and talked to our account rep and was told that if we switch to Stripe credit card processing it will fix the issue. We are using WorldPay. Wanting to know if all of you having problems are using WorldPay or if you are already using stripe? Also, if you were told the same thing and switched from WorldPay to Stripe did it fix this delay?

  • roosters82roosters82 Member Posts: 2

    OMG - we are having the same problem and LS keeps coming up w/ lame ideas like setting our ipad dns to manual @

    Again - this started happening around the holidays.

    It definitely is a communication problem at the point that LS tries to communicate w/ the card reader to initiate the reader.

    It can take up to 1.5 minutes sometimes - other times it's instantaneous. Random & untestable.

    I have 2 stores in 2 different locations, 2 different network providers - 2 different sets of hardware - and each is acting exactly the same. I've tried everything under the sun, and I'm an ex-IT guy w/ 30 years experience. My fear is that LS wants everyone to switch to LS payments and is consciously creating an issue w/ Worldpay to force us to consider alternatives (ie $$$). Our customers are frustrated. Our staff is frustrated.

    This needs mgmt's attention and fast!

  • CapeFearGamesCapeFearGames Member Posts: 18

    Could we kindly get an update on this from Lightspeed staff? It's extremely frustrating trying to speak to support about it since it's an issue on the Lightspeed side.

  • TreasuresofojaiTreasuresofojai Member Posts: 3

    We are having the same issue since around in February 2022. Prior to this our transactions ran just fine. Our tech is very savy and has had no luck with a solution until yesterday when as the business owner and user I was hellbent on getting this resolved. We had to spend hours again going through the router connection, etc etc. I copied this entire thread explaining yet again that this is a LS issue. They finally agreed to create a ticket to take it to the second level support. Today they called the tech back and said that our terminals are at the end of their life and will be sending us new ones. We saved the entire chat thread for future use if needed. It is total BS for a customer to have to wait up to three minutes to process their transaction!

  • gregaricangregarican Member Posts: 926 
    edited March 11 the hardware terminals (assuming provided by or at least facilitated by Lightspeed) are EOL? As the software solution provider one would think that proactive notification to their customer base would make sense. Especially seeing that the customer base is paying for the hardware and underlying support.

    Simply Googling this terminal model it does appear to be sunsetting -->

  • riversidecycleriversidecycle Member Posts: 6

    Same problem here since January maybe. Lightspeed sent out a new Verifone MX-915 and said old one was out dated. Did NOT fix the problem. They ran through some transactions and said it was within their parameters. Definitely not acceptable. Customers are very unhappy with the wait and lines form because of delay.

  • riversidecycleriversidecycle Member Posts: 6

    we use lightspeed payments btw

  • riversidecycleriversidecycle Member Posts: 6

    As a follow up....

    Tech support suggested plugging the terminal directly into router and that made all the difference.

    We had the terminal plugged into a switch and the switch into our router and that must be what was causing the delay.


  • roosters82roosters82 Member Posts: 2

    We tried this out already - took the switch out of the equation - had to run a cat 5 from the cable box to the front of the store (via the rafters in the attic which is a story for a later day) and plugged everything ethernet based directly into the Router.

    At first we had good results - and then within the same day it started the same old slow & random behavior.

    This is killing business for us - customers are very pissed off - and our high season is just about to start. If we don't get this escalated, we are screwed.

    I have tried to have level 1 support bump this up but have gotten nowhere. Is there any way to get LS engineering to look at this seriously?

  • cottoneyedjoescottoneyedjoes Member Posts: 3

    Have any of you switched to Stripe and had good results?

  • gregaricangregarican Member Posts: 926 

    Hope most of the people on this thread are aware that the MX-915 series payment terminals are being retired by the hardware vendor. Meaning they are pretty much End of Life. So the ultimate solution would be switching to a new and supported model. Lightspeed as the reseller (or at least the integrator) still listing this model isn't a good thing.

  • nutterbutternutterbutter Member Posts: 1

    It may not be just Worldpay.

    I'm on Lightspeed Payments with MX-915. Same issue of randomly long time for the MX-915 change screen to accept a payment.

    I have Richie from Lightspeed ask me via chat and email the same questions about cable length, DNS, and changing port on the router over and over again. I keep asking for him to check some kind of log file, and give him exact transactions that have performed poorly. I've sent logs with 5000 pings from my router to DNS, 5000 pings from my computer to terminal, 5000 pings from register laptop to terminal, all fine without a single lost packet.

    He replies with a question about cables. Sometimes about rebooting.

  • CVLSCVLS Member Posts: 18

    I really think they just don't know why this happens. But instead of saying that outright, they just ask you to try to change cables, run a speed test, etc... Because they don't know what else to say to us.

  • CapeFearGamesCapeFearGames Member Posts: 18

    The weird thing for us is it does the same with with our wireless Ingenico iSMP4. We have two MX-915 (one is only a few months old) and 1x iSMP4. All 3 of them have this same issue and it's driving all of our staff crazy.

  • gregaricangregarican Member Posts: 926 

    I don't think it's a payment processor issue. It's a hardware issue. If the MX-915's are being EOL'ed per the device manufacturer then that's a sign that it shouldn't be used in production. And a newer model that works with the payment processor and LSR should be implemented.

  • cottoneyedjoescottoneyedjoes Member Posts: 3

    Have any of you switched to Stripe and had good results?

  • CVLSCVLS Member Posts: 18

    Haven't used Stripe. Did you switch with good results? Do you still use the MX-915 or is it a different set up all together?

  • bznwinegallerybznwinegallery Member Posts: 1

    Exact same problem since the holidays. MX-915 & Worldpay. MX-915 was recently replaced with a new machine. Would love to figure out a resolution as the MX-915 takes upward of 3 minutes to wake up.

  • alanlloydalanlloyd Member Posts: 76 ✭

    I am trying to get this resolved again today. Terminals continue to be very slow. When I speak to LS support they tell me that there have been no known cases of this happening. I advised that they look at this community board. I have called Worldpay and they flatly told me that this is a Lightspeed problem.

    At this point, I am curious about those here who may have replaced their MX-915 terminals with other devices, and if this resolved this issue.



  • jburkeen03jburkeen03 Member Posts: 2

    I am also experiencing this issue. We have a mx915 and use worldpay. For anyone who has changed card readers has it helped?

  • jamesdarvillejamesdarville Member Posts: 2

    We are experiencing similar issues with our MX-915's and use Cayan. LS support recommended we change web browsers to resolve the issue. 🙄

  • alanlloydalanlloyd Member Posts: 76 ✭

    Changing web browsers, running cables DIRECTLY to your router, etc. are lame attempts at fixing this problem. Unless you are using some incredibly outdated browser, it won't make any difference. This is a problem stemming from lightspeed instigating whatever triggers the the terminal to wake up for the customer. period. I spent two hours on phone tech support, while at the same time using LS's chat tech support. Both support people ultimately said that I should delete and recreate the terminal in Lightspeed. So . . . thats what I did with one of my three terminals. First, unplug the terminal. Then, go into settings and go to the Payment configuration. Go to the payment terminals screen and select the terminal there. Delete it. Then, plug the terminal back in and wait for the activation code to appear on screen. Add the terminal back into lightspeed. Here's the secret sauce of this fix: The terminal will update its firmware when it boots! Once this happens, it will reboot on its own one more time. Next, I went into google chrome and deleted ALL information in the cache. This will break printing with LS Hub, as well as any saved passwords, etc. Easy fix on all.

    I have now done this on two of my three terminals / registers. So far, it seems to have made a difference. response times vary, but I have not seen it take over about 25 seconds max. . .. which beats the (sometimes) three minutes! previously.

    This whole process should take about 15 minutes for each of your registers.

    Good luck.

    Alan Lloyd, Creature Comforts - Durango

Sign In or Register to comment.