Pre-ONSITE Lightspeed Assistance

Craig T BrownCraig T Brown Member Posts: 1

Hi there,

I was hoping that someone else out there might be using an earlier version of Lightspeed like me. I've been using LightSpeed POS for 6yrs and when Lightspeed made it's change to a Cloudbased service made no sense for me to upgrade and the services provided had been working for my Small Business needs (Small Brick n Morter, Mom and Pop).

Recently when upgrading to Mac OS Sierra, my LightSpeed Server (3.9.8) will no longer Start. I've tried every online trick I can find. And Yes, my Paid Support is up and I believe Lightspeed will no longer Support my version. I was told during the Transition to Onsite that my Software would no longer be supported unless I Purchased the New Lightspeed. I understand the Tech side to this, but from a Customer Service standpoint, this felt a little like 'hi-jacking' a new Sale and the older version actually worked better for me than the new Model did at the time.

I'm dead in the water now without any way of running my POS. As we do Repair Work, it's vital that I can access my Customers information ASAP.

Any help in attempting to simply getting my Server to run would be MORE than gratefully appreciated.

Thanks!

1 comment

  • Karine_khKarine_kh Member, Lightspeed Staff Posts: 2 Lightspeed

    Hey Craig,

    The version 3.9.8 is not compatible with Mac OS High Sierra. To access Onsite, you will need to upgrade your Lightspeed to version 2016 1.3.5 or higher (if you maintenance support allows it). If you have an expired maintenance, you will need to contact your account manager to renew your maintenance.

    Here is the Link to install version 2016 1.3.5: https://www.lightspeedhq.com/pos/onsite/downloads/

    If you need further help, you can always contact the Onsite support. We are available 24-hours Monday-Sunday. 

    Technical Support, Onsite

    Lightspeed HQ

Sign In or Register to comment.